0
\$\begingroup\$

I'm getting started with learning Unreal development, and I've created a new project based off the FPS C++ template.

I've changed the key mappings inside the DefaultInput.ini, rebuilt the Visual Studio solution, and rebuilt the project in the Unreal editor, but none of my changes are taking effect.

What step am I missing?

\$\endgroup\$
  • 1
    \$\begingroup\$ Key bindings are usually done inside the Unreal editor itself, not through the DefaultInput.ini. I forget which menu item but you're looking for Project Settings then Input. \$\endgroup\$ – Stephen Nov 22 '17 at 8:28
  • \$\begingroup\$ @Stephen, Works perfectly. You should make this an answer. \$\endgroup\$ – Nightmare Games Nov 23 '17 at 0:28
2
\$\begingroup\$

You wouldn't normally edit the key bindings by changing the DefaultInput.ini. The best way to do it is use Project Settings inside the editor.

Got to Settings -> Project Settings. A new box will open up with options down the left. One of these is "Input" which you can open up and set up your key bindings or game controller settings as per your requirements.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.