1
\$\begingroup\$

Using Monogame, I'm trying to port a game to Windows Phone 8, but I'm having issues getting a basic example to run.

When I create a basic Mono project and run it on my phone (to check everything's OK), it compiles the game, and deploys it to my phone, but when the app starts running, the debugger throws this error:

TypeLoadException from debugger

I tried adding a reference of that .dll, but that doesn't solve it. This is the first time that I use Monogame, so please bear with me.

\$\endgroup\$
2
  • 1
    \$\begingroup\$ What version of monogame are you using. It may be a problem if you are trying to use an older Monogame version. \$\endgroup\$
    – Shroeder
    Oct 21, 2014 at 14:52
  • \$\begingroup\$ i'm using Monogame 3.2. i'm still in the struggle to make it run. :/ \$\endgroup\$ Oct 21, 2014 at 16:08

1 Answer 1

0
\$\begingroup\$

I believe you are running into the same issue as below. It is fixed in the development branch.

MonoGame 3.2 installer installs Windows (DX) framework assembly into WindowsGL

You can check by following these steps.

Install MonoGame 3.2, then inspect Assemblies/WindowsGL/MonoGame.Framework.dll in ildasm. The assembly manifest is referencing SharpDX instead of OpenTK. The assembly is a copy of Assemblies/Windows/MonoGame.Framework.dll.

Checking out the original branch, building the project, and then running the installers should fix your issue. Additionally reinstalling WindowsGL should solve the issue.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .