2
\$\begingroup\$

I'm attempting to lightmap bake my scene and am running into the following problem -

With the lights set to realtime, the shadows have a nice amount of detail in them and the lighting on the models looks correct. However after a bake, all I end up with is a dull blob shadow underneath everything and nasty shading marks on my meshes, these shading marks are mostly appearing where the seams are on the UVs. The models are .blend files from Blender and 'Generate Lightmap UVs' is checked on the model Inspector panel.

All lights are set to static and 'Baked'

Lights are 3 x spotlights 1 x directional light

All models are set to static

Unity 5.3.3

PC standalone

Materials are using the standard shader with a diffuse and normal map on each.

I have attached screenshots of the problem and all my settings.

This is my first proper attempt at lightmapping, so I'm hoping it's just a simple oversight in my settings that someone more experienced can point out.

If anyone can suggest the cause of the problem, it would be much appreciated.

Thanks in advance

enter image description here

enter image description here

\$\endgroup\$
2
\$\begingroup\$

Increase atlas size to 4096. [Lighting tab >> Baked GI >> Atlas size]

Tested with your settings:

enter image description here

Increase bounce intensity of light. Also increase indirect intensity and bounce boost under General GI in Lighting tab. These should be satisfactory. If not put some bake only point lights where shading is not working good. Then bake.

\$\endgroup\$
  • \$\begingroup\$ While it didn't solve the shading issue, it was the correct solution to the shadow resolution issue - thanks. \$\endgroup\$ – NIMBLE JIM Jul 16 '16 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.