1
\$\begingroup\$

I'm running into an issue about some lightmap glitches made of black seams lines occuring only in the standalone build of our game, and it does only affect certain scenes. below is attached a screenshot of both editor and .exe build of the same scene.

enter image description here

I'm also attaching below the current Lighting settings for that current scene, but before, our second UV Channel is not generated inside Unity3D but authored in 3DSMAX :

enter image description here

Now, even if the generated lightmaps are 4096, their texture inspector shows a max size of 2048 and no compression (tried a build with a max size of 4k with no change), i also discovered that Mip Maps are enabled by default (might be the problem ?).

Above all, my build settings are Windows standalone x86, although the game is VR Only wouldn't be better to make it x86_64 only and would it solve this issue ?

Current Unity Version and infos: - Unity 5.6.0f3 - Oculus Utilities 1.14 - Build settings for windows: Auto graphics API - Static/Dynamic Batching - GPU Skinning - VR supported (Oculus + OpenVR) - MultiPass Stereo Rendering - Optimize Mesh Data enabled.

Mesh import infos:

Mesh compression off - Read/Write enabled - Optimize Mesh Enabled - Normals: Import

i would also state that we had a previous gearVR build (with 2048 resolution lightmaps) and this issue was never encountered

Thank you.

\$\endgroup\$
0
\$\begingroup\$

Solved, The issue here was in Build Settings > Vertex Compression that was turned to "everything", unchecking the UV1 channel (the second channel used for lightmap UVs) solved this issue.

\$\endgroup\$
  • \$\begingroup\$ You can accept your own answer. \$\endgroup\$ – S. Tarık Çetin Jun 29 '17 at 22:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.