1
\$\begingroup\$

To save performance and increase the details of static shadows I marked all static objects as static in my Unity Scene. Unfortunately there are now strange patterns on some of my models and I have no clue why. Execpt the sun every light source in my scene uses the mode "Baked".

I'm using Unity 2017.1.0f3 with DX11 on Windows 10 Home x64 and a NVidia GTX 780 Ti.

This is one of the affected models: enter image description here

My Lightmapping Settings are the following:

Lightmapper: Enlighten
Indirect Resolution: 8 texels per unit
Lightmap Resolution: 80 texels per unit
Lightmap Padding: 2 texels
Lightmap Size: 2048
Compress Lightmaps: false
Ambient Occlusion: false
Final Gather: true
    Ray Count: 256
    Denoising: true
Directional Mode: Directional
Indirect Intensity: 1
Albedo Boost: 1
Lightmap Parameters: Default-HighResolution

The models were made with Blender 1.78c and the issue does not appear if I use only Realtime lights. Does anyone know this behavior and is there a way to fix it?

Thank you very much in advance! :)

\$\endgroup\$
  • 1
    \$\begingroup\$ Can you show us the UV unwrap for that model? It looks like every face might be mapped to the same spot, which would prevent the lightmapper from assigning unique lightmap texels to each part of it. \$\endgroup\$ – DMGregory Aug 20 '17 at 23:10
1
\$\begingroup\$

I just found the issue. For models without Lightmap UVs it's required to generate them. This can be done directly in Unity where you just have to tick "Generate Lightmap UVs" in the Model tab of the imported model.

enter image description here

Don't forget to apply the changes made to the import settings! I did this with all of the affected models and it solved the problem.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.