1
\$\begingroup\$

I am trying to export bullet from blender using python console however it raises an error while reaching to import PhysicsConstraints; The error says Module not found, Since bullet exporter and PhysicsConstraints expected to be present in Blender 2.71, Can anybody tell me what is this error about? I tried to run the script while I was in Game Engine (Someone suggested to do so in previous answers of a closed thread) But it didn't work too.

Thanks

Iman

\$\endgroup\$
1
\$\begingroup\$

It seems that bge module is not available while running a script in text editor or in python console with the direct command : import bge

actually there is nothing wrong with the module and there is nothing missed! only that the scripts with import bge can't be executed from console or text editor, to do so you have to add a controller to your script and press P to start game mode,Take a look at this : http://pymove3d.sudile.com/stations/blender-game-engine/a_introduction.html

Hope this helps someone...

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.