1
\$\begingroup\$

I click "Restrict renderability", so that everything except the item I want to export is grayed out. However, it still exports lights and everything when I import it into Unity.

"Restrict renderability" on cube

How can I fix this?

\$\endgroup\$
  • \$\begingroup\$ Friendly tip: You should've posted this on the blender stack exchange. You'll get better info from more experienced users. \$\endgroup\$ – Danny Aug 28 '16 at 19:26
3
\$\begingroup\$

The render visibility option only affects what is visible when blender renders a final image, it isn't used when exporting objects.

If you give unity your blend file, it can do the export/import for you and shouldn't import lights and cameras, see the unity manual for the full list.

If you are exporting manually, you should find options to control what is exported, the fbx exporter has an option that lets you turn off the export of cameras and lights, while the obj exporter can be set to export only selected objects.

fbx options - fbx options

obj options - obj options

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.