4
\$\begingroup\$

Version: Unity 2020.2.0f1

I started my project with Universal Render Pipeline template but I don't know why all materials are pink. I even tried to upgrading but nothing happened.

This error was coming after upgrading: enter image description here

And when I am creating new materials then I still getting pink materials and I am also not able to upgrade them:

enter image description here

\$\endgroup\$

6 Answers 6

5
\$\begingroup\$

To upgrade built-in Shaders (ref):

Open your Project in Unity, and go to Edit > Render Pipeline > Universal Render Pipeline. According to your needs, select either Upgrade Project Materials to URP Materials or Upgrade Selected Materials to URP Materials.

\$\endgroup\$
1
  • \$\begingroup\$ I got TrailFollowMaterial material was not upgraded. There's no upgrader to convert Legacy Shaders/Particles/~Additive-Multiply shader to selected pipeline UnityEditor.Rendering.Universal.UniversalRenderPipelineMaterialUpgrader:UpgradeProjectMaterials() (at \$\endgroup\$
    – Ramon Dias
    Apr 21, 2022 at 13:53
1
\$\begingroup\$

A way I've managed to fix this is by right-clicking on the Project then selecting "Reimport all".

\$\endgroup\$
1
\$\begingroup\$

In addtion to what has being said, you might check if there is indeed a Render Pipeline selected in your project.

Go to Edit > Project Settings > Graphics

Check if Scriptable Render Pipeline Settings is not marked as None.

If it is None you'll certainly experience pink materials.

Scriptable Render Pipeline Settings

\$\endgroup\$
1
\$\begingroup\$

I followed all the steps above and only ran into trouble with upgrading materials.

I'm using Unity 2022.3.18f1 and found the final step to upgrade materials is actually now:

*select materials

Edit>Rendering>Materials>Convert Selected Materials to URP

\$\endgroup\$
0
\$\begingroup\$

First of all, you need to create a URP asset. To do so, right click in the project window and choose create/Rendering/URP asset. Then make sure that this asset is set to your scriptable render pipeline setting. (check Edit/Project settings/Scriptable Render Pipeline Setting). on the final steps, you can Upgrade your materials by going to Edit/Render Pipeline/Universal Render Pipeline/Upgrade.

\$\endgroup\$
0
\$\begingroup\$

Finally I fixed it; just downgrade your URP from 12.0 to an older version.

\$\endgroup\$
1
  • 2
    \$\begingroup\$ This answer would be even better if it explained how to perform the downgrade, and which version worked for you. \$\endgroup\$
    – DMGregory
    Jun 5, 2023 at 20:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .