0
\$\begingroup\$

I going through the "Ruby's Adventure: 2D Beginner" tutorial, chapter 4, section 3 with Unity 2019.11.

In the tutorial you create a folder for tiles and you are then supposed to right-click in the asset folder and select "Create > Tile" from the menu. There's even a screenshot showing the menu where the option is right below the sprite sections. However, in version 2019.11 of unity, there is no such option :)

I checked the documentation, and for 2019.3 and 2020.1 the manual states that this should be possible via the assets menu (there's no docs for 2019.11 specifically), but my Unity editor doesn't have the option.

It seems unlikely that the option is just missing from my version, so I'm guessing something about my project setup is wrong. Is there anything special I need to set up to have the project support tiles?

Edit: I found the feature in the 2018 LTS version. I'm new to Unity, so maybe out of date documentation is the norm.

\$\endgroup\$
  • 1
    \$\begingroup\$ Unfortunately, documentation often doesn't get updated between major releases; at least not very quickly. \$\endgroup\$ – Jesse Williams Nov 16 at 18:43
3
\$\begingroup\$

The tutorial, "Ruby's Adventure: 2D Beginner" is a 3D project.

I restarted the tutorial and changed it to 2D using the menu "Edit -> Project Settings... -> Editor -> Default Behavior Mode".

Next, I followed Cedric Degottex's suggestion in the comments for the tutorial by opening "Window > Package Manager", and installing the "2D Sprite" and "2D Tilemap Editor" packages.

I'm leaving this here in case anyone else hits this relatively minor snag.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.