0
\$\begingroup\$

Before 2 weeks ago I can develop games on Ubuntu with Unity3D but after some updates or somethings I give "all compiler errors have to be fixed before you can enter play mode" messages. If I compile code on Intellij Rider it's ok, no problem. There is nothing on Unity console and I am researching about it since 2 weeks but I can not find any solution. I tried to install mono and .net core, yesterday find line ending problem an try to different editor but they don't work.

Produce Steps:

  • Create new 2D project

  • Add empty object to scene

  • Add script to empty object

  • Compile

ubuntu: 18.04

unity3d: 2017.4.26f1 and 2019.1

\$\endgroup\$
  • 1
    \$\begingroup\$ It doesn't look like we have enough information about the code that Unity thinks is generating a compiler error for us to be able to reproduce this issue. Can you reproduce the problem in a new, empty project? Try to provide us with a minimal, complete, verifiable example that fits into the body of your question (not an external link), so other users with Ubuntu can test it. If you don't think it's anything in your code or project setup that's at issue, then this might be a bug to report to Unity support instead. \$\endgroup\$ – DMGregory May 10 at 10:15
  • \$\begingroup\$ I added produce steps. Script is created from scratch. \$\endgroup\$ – Cagdas May 10 at 14:17
  • \$\begingroup\$ And you don't get any errors when you compile the project? \$\endgroup\$ – Vaillancourt May 10 at 14:19
  • \$\begingroup\$ This is just the default script template, with no additional typing whatsoever? Did you name the script anything in particular? \$\endgroup\$ – DMGregory May 10 at 14:20
  • \$\begingroup\$ @AlexandreVaillancourt I get error but can not see on console, only red exclamation but it compiled on Rider from Intellij. \$\endgroup\$ – Cagdas May 10 at 14:21
1
\$\begingroup\$

Finally I find solution. First, I tried to compile on MonoDevelop and it compiled successfully but one error. It was about /usr/lib/mono/* after than I changed owner for this directory with sudo chown -R $USER:$USER /usr/lib/mono/ and it works!

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.