1
\$\begingroup\$

I am just finishing up my first game for the One Game A Month challenge which I wrote with the current MonoGame framework in Xamarin for Windows. I built the program in release mode, but running the executable produces a console window besides the game window. The console stays empty unless I deliberately cause an error to be logged, say by removing a required resource.

How can I get rid of this extraneous console window?

I looked through the project settings, but saw nothing alluding to removing the console window...

\$\endgroup\$
2
  • 2
    \$\begingroup\$ Nevermind. Found that changing the build settings to Executable with GUI from just Executable has solved the issue. \$\endgroup\$ Jan 29 '14 at 17:09
  • 3
    \$\begingroup\$ You should answer your own question then =) \$\endgroup\$
    – Grey
    Jan 29 '14 at 17:23
1
\$\begingroup\$

Found that changing the build settings to Executable with GUI solved this problem.

\$\endgroup\$
0
\$\begingroup\$

Basically, change the configuration of Build "Console Application" to "Windows Application".

Config sample

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.