I have a Visual Studio C++ project. I've just started out with SDL, and I've already rendered images, text, and now I'm trying to play audio. This will be done with the SDL_Mixer extension library.

However, I'm having the following issue. When I run my code with the SDL_Mixer library included, I get the following popup error message:

The procedure entry point SDL_AudioStreamFlush could not be located in the dynamic link library...

What the heck does this mean? Did I do something wrong with the installation? I got SDL mixer from here: https://www.libsdl.org/projects/SDL_mixer/

Any help would be greatly appreciated!

  • \$\begingroup\$ What about this: stackoverflow.com/a/14094017/637987? \$\endgroup\$
    – Vaillancourt
    Commented Nov 12, 2017 at 4:07
  • \$\begingroup\$ Um so when I downloaded SDL_Mixer I just used the SDL_Mixer.dll that came with the download. Basically, I downloaded the folder, modified project properties to link the library, and then copied SDL_mixer.dll to the project folder along with all of my other DLLS. So they all came from the same download! \$\endgroup\$ Commented Nov 12, 2017 at 4:53
  • \$\begingroup\$ I've played around with this some more. SDL_TTF version 1.2 (the other download on the SDL website) doesn't work either! \$\endgroup\$ Commented Nov 13, 2017 at 21:28

1 Answer 1


I solved the issue! Basically, I didn't have the latest form of SDL2. (I think I had 2.0.5 or something)

By going to the SDL2 download page, I was able to get and install SDL-2.0.7, replacing the old version. Once I completed the update, I was relieved to hear my music playing!

  • 1
    \$\begingroup\$ You can go ahead and accept your own answer. Leave the question+answer up for the next person who hits the same or a similar issue. \$\endgroup\$ Commented Nov 14, 2017 at 2:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .