1
\$\begingroup\$

I'm having some trouble connecting Unity Remote 4 to Unity 5. I'm using a Samsung Galaxy S5. I've searched a bit and the other solutions with other phones aren't working for me.

What I've tried so far:

I installed the Android SDK by using Android Studio. I'm not sure if that's part of the problem but either way. I installed the Google USB Driver, the 5.0 (API 21) and 5.1 (API 22) SDKs. My phone is running on Android 5.0. All the SDK tools (Platform tools and build tools) are installed. I set USB Debugging, Stay Awake and Allow Mock Locations in the Developer Options on my phone. I set the Android SDK path in Unity (Program Files/Android/android-sdk) I set, in the Unity Editor Settings, Device to Any Android Device. I made sure my computer sees my phone, which it does. And I tried to open Unity first then the Unity Remote and Unity Remote first then Unity Engine. And set Android as my Platform in Build Settings. And I've tried plugging my phone in a USB 2.0 and a USB 3.0.

All that and each time I press the play button nothing happens in the phone. I have no idea what I'm doing wrong. I tried using Unity 4 and Unity 5.

If my OS is a factor, I'm using Windows 7 Ultimate, 64-bit.

If the following information is needed:

Hardware Version: G900P.04

Model number: SM-G900P

Android version: 5.0

Kernal version: 3.4.0

If any other information is needed I will provide it. Anyone have a solution to my problem? Thank you.

\$\endgroup\$
1
\$\begingroup\$

Oh yeah, the unity remote app can be a pain in the ass. It seems like you set up everything correctly. To see if everything works fine just try to build and run the app for your phone... if it can be built and pushed to your phone everything should be alright.

If you can push the app through unity on your phone I hopefully have a solution for you, which worked for me every time I had problems with the remote app: 1.) Plug in the phone to your computer 2.) In Unity go to Edit->Editor and switch the Unity Remote Device to "None" 3.) Restart Unity 4.) Start the remote app on your phone 5.) Once again in Unity go to Edit->Editor and set the Unity Remote Device back to "Any Android Device" 6.) Press the play button or control+p and hope for the best

\$\endgroup\$
  • \$\begingroup\$ I am unable to test this until a few days from now. If it works by building it to my phone and I am unable to test it seems like I'll be building every time I want to play test. haha What a pain that'll be. I got another answer on the Unity Answers site to try as well. Thank you. \$\endgroup\$ – coderage9001 Apr 21 '15 at 22:36
  • \$\begingroup\$ If you are able to build it to your phone, you're not far from connecting it to remote. An important side note: When using the remote app, the app isn't actually running on your phone, it will just stream a video to your phone and read your input. I once had a case, where a null pointer exception was handled totally different on the pc than on the phone. So be sure to make a build every once in a while just to see if the performance is still good and there are no errors. You can also read the debug logs with something like logcat (on eclipse) to see the problems. \$\endgroup\$ – Johannski Apr 23 '15 at 7:29
  • \$\begingroup\$ These instructions deliberately involve opening Unity Remote while Unity is already running. In my experience, Unity Remote must be opened and connected BEFORE you open Unity. This was literally the only thing I had to change before it started working for me. \$\endgroup\$ – Gnemlock Sep 4 '16 at 4:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.