1
\$\begingroup\$

So I realize the common way for animations to be done is in-place with sliding feet, then control the animation playback to coincide with the character's feet, etc. However, given a scenario such as a chess game, where you'd want to play an animation of the chess piece moving forward, then when it stops you'd want its root position updated so the next animation that played would start from the new "square." Note that this is just an example, and that the same requirement could be in place for a person doing a ground roll, a blobular mass moving forward, etc. Rather than try to type everything I tried here, I have put together a short 8 minute screencap walking through the exact steps I took to replicate the issue in Blender 2.7 and Unity 5.

http://youtu.be/BZll5aisY7k

Basically, the "Apply root motion" option does not work as expected (or at least as I expected). in the end, I'm looking fir a viable way of doing in-place animation in Blender and getting the root motion to be properly applied in Unity.

Let me know if you need any specifics, thanks!

EDIT: A (rather lengthy) tutorial on the 'right way' to do it. I geared it towards novice-level users, so it goes through the modeling, rigging, animating, exporting, and Unity steps, but if you're here looking for the solution to this question, there are annotations pointing to the different sections. https://www.youtube.com/watch?v=yKP2Qy-yKhE

\$\endgroup\$
3
\$\begingroup\$

OK, after much button mashing, I figured it out:

If you click on your main FBX object, in the inspector you will find 3 buttons at the top. The ones we care about are Rig and Animations. If you go to Rig and drop down the "Root node" selector, then choose your root bone, it will open up some more options under the Animations button. Go back to the Animations button and pick one of your animations. You will now see a series of Root Transform (Rotation / Position) areas, just under Loop Time. Check Loop time, Uncheck Loop Pose, make sure all the "Bake" options are unchecked, and change all the Root Transform "Based Upon" dropdowns to Original. This is apparently what was screwing me up... some were set to "Root Node Rotation" (seemingly at random), and this was causing me to loop in place or move opposite the root bone direction.

I'll post a new vid here once I make it, showing the correct procedure from start to finish for those searching for a similar issue. Thanks!

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.