1
\$\begingroup\$

I'm using LibGDX with GWT to create a web version of an app that runs without problems on the desktop, Android and iOS. However, the HTML version of the app had a few problems with constructs unsupported by GWT. I've fixed these issues and I get a proper HTML/GWT app that I can start within my browser.

However, I found some additional problems and I've fixed the first one but the changes are ignored by the GWT compiler: I still get the same error. This is when using Eclipse but also when doing stuff via the Windows command prompt.

I've tried the following:

  • Cleared the browser cache (Chrome, Firefox won't run but that's a different problem)
  • Removed all Gradle cache files from my home directory
  • Removed all generated files (gradlew.bat clean)
  • Re-imported the project in Eclipse
  • Rebuild the Gradle model in Eclipse
  • Use the "Dev Mode On" bookmarklet to force development mode
  • Use the "Dev Mode Off" bookmarklet to force release mode

In all cases the web app still fails to run properly and I get the same error in the JavaScript console.

Any suggestions on how to proceed here?

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.