0
\$\begingroup\$

I am working on a fps game but I cant get the size right of my map in blender, every time I export it to a .fbx file (unity won't work if it is a .blend file) it is a super small plane floor in unity the player controller is 10 as big as the map. I don't know what to do.

\$\endgroup\$
1
\$\begingroup\$

Scaling in Inspector

When you import an FBX file in Unity, it is scaled to 0.01 of its original size. You can either put it back to 1 (or anything you want) in the Model tab of the Inspector every time you import something, or you can make a small script that will do that for you whenever you import an asset.

\$\endgroup\$
0
\$\begingroup\$

Either change its scale from the Inspector after selecting the game object or the pixels per unit value of the exported asset from Import Settings (the menu when you choose the exported asset in the project hierarchy).

\$\endgroup\$
0
\$\begingroup\$

All you need to to is just remember one rule of thumb.Although I couldn't find any documentation on this.But with little workout I found that for Cube,Cylinder and Sphere[*]

50 Blender units = 1 Unity unit

So You can do either of these:

1.Scale Your Objects 50x in Blender "Just" before exporting (By Hitting S and then 50,which will uni formally scale your Object 50 times in all axes).

2.Or Import Your Objects in Unity as it is, and in Transform Panel -> Scale, Change every Value to 50.

[*] These Standard Primitives in both Programs spawn with equal Dimensions.But a Plane Does not(It is Larger in Unity)

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.