1
\$\begingroup\$

I have a problem with NGUI for Unity, using the Unity 2D Sprite objects.

First, have this image:

enter image description here

And then create an NGUI Unity 2D Sprite object in the scene. Apply this image and you get this:

enter image description here

Very odd. This doesn't happen if you use an Unity UI Image object or a SpriteRenderer component. But I really need to use NGUI's Unity 2D Sprite.

Then I ran the scene in several devices. Some of them display the sprite correctly - but others do not. Look:

enter image description here

  • Top-left device: iPad Mini 1: The sprite is bad.
  • Top-right device: iPad Mini 3: The sprite is good.
  • Bottom-left device: iPhone 5c: The sprite is bad.
  • Bottom-right device: iPhone 6 plus: The sprite is good.

I fail to understand what is the problem.

Again, this doesn't happen with sprites rendered with SpriteRenderer or Unity's builtin UI Sprite system. However, I need to do this with NGUI.

NGUI has a "NGUI Sprite" which I believe does work. But I don't want to use that one - I need to use the "NGUI Unity 2D Sprite" option.

Any ideas?

Unity 5.0.0b20

\$\endgroup\$
1
\$\begingroup\$

Found the solution.

In the inspector, uncheck Generate Mip Maps and now it will work.

I do not know why did Mip Maps affect NGUI however. Either way I've reported this in their support forums.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.