2
\$\begingroup\$

I'm trying to work out why my game is loading a large sprite atlas that I don't think it should be. The snapshot view of the profiler shows that the atlas is loaded. The references pane shows that it's loaded through a scriptable asset object. That object does indeed reference the sprites in the atlas - but I don't think the object is referenced in the scene at the moment. The game boots to this scene, so the atlas should not be loaded.

I've replicated this profiling on both the editor and on android, so it's not an editor-only thing.

When I right-click on the scriptable object in the project view, while the game is running, and Find References In Scene, it shows a few game objects. None of these objects seem to reference the scriptable object. None even have monobehaviours with fields for this type of scriptable object. Some are new-UI button objects, that have Canvas Renderer, Image and Button scripts only. None of which could be referencing this scriptable object.

Has anyone seen this behaviour before? What's going on?

\$\endgroup\$
  • \$\begingroup\$ +1 for testing even outside the editor (sometimes resources loaded into editor appears in the profiler).It seems weird. Try to open the yaml scene files and have a look if any object is referencing that resoruces (maybe an hidden one, or something stored in the scene file but that actually for any strange reason or bug doesn't appear into the scene). \$\endgroup\$ – Heisenbug Jan 31 '15 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.