1
\$\begingroup\$

Sup?

I've been working on a new environment scene inside 3ds max. It looks something like this -

enter image description here

When I used the cry engine exporter to export my assets onto my level, I've been getting very weird shadow/texture problems. Do any of you know why that's happening? I'm pretty new to all of this, especially cry engine. Here's a screenshot of the same environment inside of cry engine sdk. If you look to the left of the environment, you can see how I'm getting weird results. The area I'm having issues with is highlighted with a faint blue line.

enter image description here

\$\endgroup\$
  • \$\begingroup\$ try a smoothing group on those surfaces. \$\endgroup\$ – RoofMonkey Feb 12 '15 at 4:55
1
\$\begingroup\$

Those models look extremely detailed. If this was done with subdivision, it would not be too hard to step over the 65536 vertex limit (I'm guessing that the game could be using 16-bit vertex indices for these models).

It only takes a grid of 256x256 vertices to be right on the limit, 8 subdivision levels on a quad would go over it.

| improve this answer | |
\$\endgroup\$
0
\$\begingroup\$

I am guessing that you mean that the pipes' insides are invisible. This is because backfaces are culled on polygons. It is usually disabled either by turning off backface culling, or just duplicate the polygons with reversed winding order (or scaling them by -1).
For Cryengine, specifically I don't know how would you disable backface culling (in DirectX you can disable it in the Rasterizer state object), but the second option can easily be done in the modeling tool of your choice.

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ Looks like I was not clear enough. The backface thingy is not an issue. I've uploaded a new image with hightlights to show where I'm having problems with. It's the weird shadow/texture issue on the circular round things. You can open the image on a new page to see it clearly. \$\endgroup\$ – Lordking Jan 21 '15 at 20:14
  • 2
    \$\begingroup\$ Are you sure that every triangle is connected to precisely 3 other triangles? These weird kind of shading artifacts can arise when you have an improperly created model. Make sure there's no weird vertices or edges where there shouldn't be any. \$\endgroup\$ – user39686 Jan 21 '15 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.