0
\$\begingroup\$

I need to import a few sprites (background platform and sky) into my game scene but it seems that their quality after importing into Unity is too bad (they are blurred). The original resolution of this two images is big enough (2048 X 400 for background) and they are looking very nice in standard Windows image viewer. Here are the settings for these two textures:

maxSize = 2048 Format = truecolor TextureType = Sprite(2d)/nGUI FilterMode - point

I am using Unity2D 4.5 Target resolution of my project is 1280*800.

Can anyone help me to solve these problem? As you can see the grass on foreground looks very bloory (1 picture) Texture settings (2 picture) Original image (3 picture)

enter image description here enter image description here enter image description here

\$\endgroup\$
  • \$\begingroup\$ It might help to include a screenshot as part of the question. \$\endgroup\$ – Kelly Thomas Oct 7 '14 at 15:25
  • \$\begingroup\$ Okay, I added pictures. \$\endgroup\$ – bukka.wh Oct 7 '14 at 15:44
  • \$\begingroup\$ Don't use Point filtering. Bilinear or Trilinear should look much better when scaled. \$\endgroup\$ – bummzack Oct 7 '14 at 15:52
  • \$\begingroup\$ bummzack, I changed filter mode to trilinear, still no success(((( \$\endgroup\$ – bukka.wh Oct 7 '14 at 16:37
  • \$\begingroup\$ What format are they in? .png? .jpeg? Etc... \$\endgroup\$ – Savlon Oct 8 '14 at 5:13
1
\$\begingroup\$

If they get blurred be aware to import them in "Advanced" mode and disable "Mip Mapping" generation. Next check if any level of compression or filter is applied. Sometimes the filter tend to eat details of your image (try Point Filter or Bilinear Filter with small Anisotropic Level) Also the best result is obtained when your textures are painted "pixel perfect" in your scene. Try to import them as Truecolor without compression As a last resource try to import them in "GUI/Editor Legacy Mode"

\$\endgroup\$
  • \$\begingroup\$ Thank you! I'll try to change these settings and i'll write later about my success \$\endgroup\$ – bukka.wh Nov 13 '14 at 12:38
0
\$\begingroup\$

Click on the resolution panel, in the Game section of the Editor, and then uncheck the "Low resolution" checkbox. I think they check that so the execution is faster when testing, but it blurs everything out and makes things look bad.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.