when I run Milkshape 3D on my 64-bit Windows 7 machine, certain joints expand when I try to rotate them.

For example, my model's leg has hip, knee, foot and toe joints. So to do a walking animation I would rotate the hip joint, then rotate the knee joint. Then as soon as I start rotating the foot, the foot joint moves away from the knee rather than just rotating around the axis.

These images show what I'm talking about:

Before rotating the foot After rotating the foot

I've tried to run Milkshape in comaptibility mode and with the Mesa software OpenGL renderer, but it doesn't work. At the moment my workaround is to run Milkshape in a 32-bit Windows XP virtual machine.

Does anyone know what causes it and how to solve it?

  • 4
    \$\begingroup\$ Now there's a tool I haven't seen in a long time. \$\endgroup\$
    – jzx
    Feb 24 '15 at 21:02
  • 2
    \$\begingroup\$ I'm voting to close this question as off-topic because it is about a bug in a closed-source tool best reported to its developers. \$\endgroup\$
    – Anko
    Oct 23 '15 at 18:51
  • \$\begingroup\$ Milk Shape???? Long time!!! \$\endgroup\$ Dec 22 '15 at 21:56
  • \$\begingroup\$ turn on inverse kinematics if it is there \$\endgroup\$ May 23 '16 at 9:44

From the images it looks like you're actually extending your shin bone by moving the ankle joint (the shin is abnormally long in the second image). Makes sure the joints are parented to each other and that when rotating, the joints rotate around their base, and not around a center much farther away (which would cause translation too). For example, ensure the Rotate command is rotating around the Center of Mass, and not the origin or a user specified point.

Work through whatever tutorial you're using again, to make sure you didn't miss a step. Or follow another tutorial.

  • \$\begingroup\$ No, that's not it. My Rotate is around the center of mass, and the other joints do rotate around their base. It's only specific joints at the extremeties of the model (like tha ankles and the wrists) that exhibits this problem. It also does not explain why it works in the Win XP virtual machine. \$\endgroup\$
    – iWerner
    Sep 28 '14 at 16:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .