1
\$\begingroup\$

I've been working on making lightmaps for a game on mobile devices (meaning that individual texture sizes cannot exceed 2048 and that file size needs to be as small as possible), but I'm running into some problems that I cannot seem to fix.

The most glaring problem (as can bee seen in the attached picture), is the appearance of these "rough edges" (I'm not sure what to call them) that appear on or around certain objects that occur wherever two meshes intersect with eachother. During rendered previews, both by camera and Rendered Mode, the quality of the lights and shadows look just fine, it is only after baking that these problems are visible.

I've tried simply making the lightmap textures larger, but even that does not remove the problem, not to mention that even the roughly 3x3 foot rock in the picture is using a 512 image just for that 1 rock (and giving each object in the scene a individual lightmap will create a massive game size for a mobile device). I've tried playing with AO and Environment Lighting, and I've tried changing lamp light settings and have not made any progress.

Any ideas on how to fix or improve this result are appreciated.

Other Notes: -I'm using Full Render on baking, with margins at 8 (I've set them to 15 and have not noticed any difference). -I'm using Bledner 2.69 as seen in render preview

after baking

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.