0
\$\begingroup\$

When I zoom in on my terrain it goes white: terrain The further in I zoom, the greater the whiteness becomes. Is this normal? Is this to speed up rendering or something? Can I turn it off? terrain

I'm also getting these error messages in the console over and over again:

rc.right != m_GfxWindow->GetWidth() || rc.bottom != m_GfxWindow->GetHeight()

and

GUI Window tries to begin rendering while something else has not finished rendering! Either you have a recursive OnGUI rendering, or previous OnGUI did not clean up properly.

Does this bear any correlation on the issue?

Update I create virtual desktops to flit between using the program Deskpot. Turning this program off and restarting has stopped the above errors appearing in the console. However, I still get white terrain when I zoom in. Not a single error message.

I've restarted my computer to no avail.

I have an Asus NVidia GeForce GTX 760 2GB DDR5 Direct CU II OC Edition Graphics Card. Any known issues?

Update I don't think it's fog...

enter image description here

enter image description here

\$\endgroup\$
  • \$\begingroup\$ well, have you actually tracked down the source of that error message? It sure sounds like you're doing something wrong in your code; don't just ignore error messages, actually go to the line they indicate. \$\endgroup\$ – jhocking May 29 '14 at 1:08
  • \$\begingroup\$ @jhocking There is no line. Seriously, that is the entirety of the error message. I thought it was something to do with my Graphics Card rather than any script \$\endgroup\$ – Starkers May 29 '14 at 1:10
  • \$\begingroup\$ No, it shouldn't. A better question is "why" this is happening. \$\endgroup\$ – Josh May 29 '14 at 1:11
  • \$\begingroup\$ It could be fog settings. \$\endgroup\$ – LVBen May 29 '14 at 1:33
  • \$\begingroup\$ Do you have two terrains or only one? \$\endgroup\$ – LVBen May 29 '14 at 2:04
3
\$\begingroup\$

Check your Fog settings in the Edit/Render Settings menu. If you set the Linear Fog Start higher than the Linear Fog End, you can get this type of effect.

Try turning off the Fog completely to see if the problem goes away.

I was able to reproduce your issue with fog:

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Was so sure you were right :( But I don't think so (updated answer) \$\endgroup\$ – Starkers May 29 '14 at 1:55
  • \$\begingroup\$ Darn! It seemed promising. \$\endgroup\$ – LVBen May 29 '14 at 2:02
3
\$\begingroup\$

I fixed the error by deleting the terrain and creating brand new terrain. This wasn't some momentary glitch though; that weird terrain remained weird after a restart, even. Hopefully the problem won't came back.

Sadly I have no idea how one could salvage terrain they've worked hard on. My only theory is that Dexpot somehow corrupts something, and my only advice is to never use it and Unity at the same time.

Dexpot is lovely program and I don't want to give it ill-credit, but I'm 99% sure it was causing that

GUI Window tries to begin rendering while something else has not finished rendering! Either you have a recursive OnGUI rendering, or previous OnGUI did not clean up properly.

error, and qutting Dexpot and recreating the terrain has solved the issue, so it does look like its the culprit. Hopefully I've nailed it.

terrain

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.