0
\$\begingroup\$

I'm working with Unreal Script, and I need to use Canvas instead of Scaleform to create a HUD. I've extended the game type from UTGame, and used bUseClassicHUD in the Default Properties section, but the default Scaleform HUD continues to appear. I know for certain that I have everything configured properly to load and run the scripts, but this one line just doesn't seem to have any effect.

DefaultProperties{

// Disable the scaleform (flash) HUD in the UTGame
bUseClassicHUD = true

// Initial score value
nScore = 0

// Initial time value
m_gameTimer = 30.0

}

Is there something else I need to include? I've done a reinstall (I'm using the July 2013 build), but to no avail.

\$\endgroup\$
1
\$\begingroup\$

After moving the opening curly brace onto the next line, the code worked as intended. I'm not sure why it has to be on a separate line here in particular, but it solved the problem.

\$\endgroup\$
  • \$\begingroup\$ Ah! Unreal's parser has improved a lot over the years, but it still can be finicky. I guess it didn't like your defaultproperties block. \$\endgroup\$ – Phillip May 17 '14 at 19:39
0
\$\begingroup\$

Are you sure it's the scaleform HUD that's appearing? I'd try logging out the newHUDType parameter you're getting in ClientSetHUD(). If bUseClassicHUD is true, it looks like you should be getting the UTHUD class (granted, I have an older drop of UDK, so things may have changed in more recent builds.

\$\endgroup\$
  • \$\begingroup\$ Yeah, it's definitely the scaleform HUD still. The HUD class that I'm making is extended from the standard HUD class, does it need to extend from UTHUD for Canvas to work? \$\endgroup\$ – Daniel May 17 '14 at 0:01
  • \$\begingroup\$ No, that should be fine. \$\endgroup\$ – Phillip May 17 '14 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.