I currently have two versions of Unity on my Windows computer. I would like to not update my projects to avoid compatibility issues like I had in the past.

Installation in another folder goes just fine, but when I try to open Unity, it says that another Project is already opened and that if I want to continue I must update it. If I close this window, Unity aborts as well.

Is there a way to avoid this behaviour?


4 Answers 4


Hold down the Alt key when starting Unity. It will bring up the list with your available projects and will let you open a new one.


OP's Answer (If you know an easier way to do so, please post it! :D )

The last opened project path is saved on a Registry Key in HKEY_CURRENT_USER\Software\Unity Technologies\Unity Editor 4.x

In my computer, kProjectBasePath_h4113231939 is the key I'm talking about. You just need to delete its value to achieve the result. To do so, execute regedit, navigate to the path above, locate the key, right-click it, select Edit and delete the value.

If you frequently need to switch between Unity versions, you may want to create a file that does these operations for you, so that you won't need to do that over and over again.

Create a txt file and paste this:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Unity Technologies\Unity Editor 4.x]

Then change the extension to .reg. Opening this file will automatically delete your registry key value.


You can set Unity to always ask you which project it should open on startup. That way you can easily choose the compatible projects for your Unity version.

Just go to Edit > Preferences... > General

Then make sure the checkbox for "Always show Project Wizard" ist activated.

And you can press the "Alt" Key while you are starting Unity to force it to show you the Project Wizard. For me this isn't working when I use a Desktop Shortcut to open Unity on Windows 7. When I open it with the Startmenu, it does.


You can start another instance of Unity from the CommandLine/Terminal, and then specify the project path you would like to open with that instance. If you specify wrong path to project, Unity will show you project selection screen.

Under MacOS, you can launch Unity from the Terminal by typing:

/Applications/Unity/Unity.app/Contents/MacOS/Unity -projectPath pathToProjectOrAnyString

while under Windows, you should type to the CommandPrompt:

"C:\Program Files (x86)\Unity\Editor\Unity.exe  -projectPath pathToProjectOrAnyString"

As I mentioned, if you specify wrong project path you can then choose any project you like. That should avoid the Upgrade project question. Using CommandLine gives you better control on what project you open with which instance.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .