2
\$\begingroup\$

I've made an animation in 3ds Max and want to export it to .fbx and import it into Unity. I've done this once without problems. But this time, my .max file is 2,8MB and my .fbx file came out a huge 630MB!

There's nothing wrong with my model: I exported it from a Blender model (to .fbx) and imported it to 3ds max (converted it to an editable poly) to do my rigging and animation. As soon as I import some .bip animations, I get these huge files.

Is there a safe way to get smaller file sizes? I don't mind redoing the rigging if I can solve this.

\$\endgroup\$
  • \$\begingroup\$ I am no expert, but it sounds to me like you are doing your export wrong. There has to be some options in the export that can control exactly what kind of data you are exporting. Just as a guess, if your file grew ~30 times, you maybe exporting every frame of your animation or something similar. So the issue maybe in the way you are exporting things. Have you tried looking at 3ds max forums on how to do this type of export properly? \$\endgroup\$ – Vitaly Omelchenko Apr 30 '14 at 20:34
  • \$\begingroup\$ Hmmm.. It's true that I'm exporting every single animation frame, but as far as I know, this is the only way to transfer my animation from 3DS Max into my .fbx file and from there into Unity. Also, like I said, I did this before (just once to be honest, I'm fairly new to all this) and my exported .fbx file was just 4,5MB, all animations included.. \$\endgroup\$ – abracadabra1980 May 1 '14 at 9:08
  • \$\begingroup\$ Are you using this guide by any chance? docs.unity3d.com/Documentation/Manual/… If so, try flipping various switches on and off and see how it impacts the file size. Start with bare minimum and keep adding more export options and see how it impacts your file, at the very least you will know what is causing the file to grow so big. \$\endgroup\$ – Vitaly Omelchenko May 1 '14 at 13:58
  • \$\begingroup\$ Also, I found a lot of various guides just by googling : "export from 3ds max to unity animation". I don't really know what they are about, but the people who answer and make tutorial probably know a ton about it, you could try emailing them and ask this question. \$\endgroup\$ – Vitaly Omelchenko May 1 '14 at 14:00
1
\$\begingroup\$

After numerous tests (I tried my model with a number of different animations, I tried this specific animation with different models, I even installed 3DS Max 2014) and trying out different export settings, I figured out what is causing this issue. I don't know WHY it is causing it, I mean it doesn't seem logical to me, but at least I managed to keep my own sanity..

I had my character model as a single mesh and my biped skeleton, but I had kept the eyeballs as a separate mesh, which I had linked to my head bone. The reason I did this, is because I was planning to set some facial rigging afterwards (don't know how easy it is yet, I was going to look through some tutorials later on).

For some reason whenever I choose all my objects (body mesh, bones and eyes linked the head bone) 3DS Max is working like crazy using all my RAM and I get a 600MB+ .fbx file.

The easy way to work around it is to attach the eyes to the rest of the body and export a single mesh with the skeleton. But wouldn't I lose the possibility to rig the face then?

\$\endgroup\$
  • \$\begingroup\$ Sounds like a bug to me \$\endgroup\$ – Quad Jul 31 '14 at 15:05
0
\$\begingroup\$

I import a 20MB fbx file to update some animation of a man model, then I export it as fbx but I got a 1GB huge file. The cause is the name of the imported fbx. It got non-English words in it so the 3ds Max were working incorrectly with incompatible words. So if you are living or working in a place where English is not the native language, you should check the file name or even the folder and the path.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.