I made game assets that look great in Photoshop, but they look like crap when I import then into Unity and run the game. Why?

  • \$\begingroup\$ What is the exact problem you are facing? What have you tried and what did not worked? I doubt [unity] tag is relevant either. \$\endgroup\$ – Kromster says support Monica Apr 15 '14 at 6:23
  • \$\begingroup\$ My problem is that I've med graphics in photoshop that is just stellar :), but they look like crap when I use it in Unity. I made a png to be the texture of å button for instance, the text in the image looks a bit blurry from the supersharp look in photoshop when I made it \$\endgroup\$ – Jason94 Apr 15 '14 at 6:34
  • 5
    \$\begingroup\$ pictures might help to understand the problem. \$\endgroup\$ – Jari Komppa Apr 15 '14 at 8:48
  • 1
    \$\begingroup\$ @Jason94: You should refactor your question to that specific issue. \$\endgroup\$ – Kromster says support Monica Apr 15 '14 at 9:40

Go to your assets window and click on the image. On the inspector, you will see the import resolution. Switch it to 2048 (it is 1024 by default). You can play with the different filter modes too. For example, I'm developing an old-school kind of game with big pixels, so I set the filter mode to "Point", so that sprites don't get shady.

  • \$\begingroup\$ Another setting that can affect this is mipmapping. If using linear filtering, and your source sprite is 133% the size that you're displaying it on screen, instead of a crisp sprite you'll get a muddy 50% blend between the 33% too-large original and a downsampled mip that's 33% smaller than you want. Mipmapping and linear filtering may be needed to get the look you want, if you have smooth sprites changing scales, but you can reduce the muddiness by choosing your original size to be close to the typial on-screen size (or larger by a factor that's a power of 2) \$\endgroup\$ – DMGregory Apr 15 '14 at 12:26
  • \$\begingroup\$ @Jason94 did this solve your problem? If so, could you mark it as solved? Thanks ;) \$\endgroup\$ – Ypsilon Apr 18 '14 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.