1
\$\begingroup\$

I can't find anything on how to hint to the driver to disable any antialias. I'm using a very minimal passthrough setup yet I notice my driver is still doing what looks like MSAA. I want to disable this, or at least give a strong hint to disable it, so to save performance. As I will be doing deferred rendering with my own SSAA.

\$\endgroup\$
8
  • 1
    \$\begingroup\$ OpenGL does no Anti Aliasing by itself. What you are looking at might be linear texture filtering. \$\endgroup\$
    – API-Beast
    Mar 24 '14 at 23:57
  • \$\begingroup\$ To better clarify what you need, please add a screenshot. \$\endgroup\$ Mar 25 '14 at 1:14
  • \$\begingroup\$ @Mr.Beast: What makes you think texture filtering is related? Question is clearly about disabling AA. \$\endgroup\$
    – Kromster
    Mar 25 '14 at 4:36
  • \$\begingroup\$ There is no way (AFAIK) to override the driver settings, since you are already overriding your application's settings using the driver, can't go both ways. \$\endgroup\$
    – concept3d
    Mar 25 '14 at 7:33
  • \$\begingroup\$ @KromStern Linear filtering makes the textures blurry, which can be misunderstood as anti aliasing, but I agree a Screenshot is needed. \$\endgroup\$
    – API-Beast
    Mar 25 '14 at 10:49
0
\$\begingroup\$

OpenGL drivers allow user to force enable AA. I'd like to see a workaround of that too, but I'm afraid there's none.

Possible solution would be to render to a texture through FBO (which is not controlled by drivers AA setting?) and then render that texture pixely-perfect to screen.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.