2
\$\begingroup\$

I laid out my iso map and it's fine, but when I add my sprite actors they get located in the correct location but they are laying down not standing up. I tried rotating them on the z by 45 but then they moved to the wrong location.

Anyone have any idea what I'm doing wrong? looks like a steam roller ran over my object :-)

I'm going to try and upload pics.

https://picasaweb.google.com/114100917691803291674/20140120?authuser=0&feat=embedwebsite

**correct location,but the image is laying down...

correct location,but the image is flate

**standing up, but wrong map position..

 i tried rotating on z, but the position was incorrect on the map..

\$\endgroup\$
0
\$\begingroup\$

It seems like you're applying the map projection transformations to the objects that go on the map. If that's the case, draw the objects on the map without these transforms.

If you provide some code, I might be able to help you further.

\$\endgroup\$
1
  • \$\begingroup\$ I've mulled over this issue for a while now and I think you are correct. I should not be applying my iso transforms to the sprites. I think I just need the coordinate conversion and a regular draw sprite. \$\endgroup\$ – Nick Tullos Jan 27 '14 at 12:40
0
\$\begingroup\$

I'm not familiar with libgdx, and you haven't provided any code showing what you're doing, but it looks like you're applying the transformations in the opposite order than you should. Swap the translation (tile position) and the rotation (orientation of the upright item), apply any needed small corrections and you'll be fine.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.