9
\$\begingroup\$

I'm trying to place a non-static pot (RuinsPot01) on a table (RuinsAltar) with the Havok simulation.

I place the pot a little bit above the table and turn on Havok. The pot falls down but is left floating slightly above the table.

If I turn of Havok and press F it is aligned correctly to the table, but as soon I turn on Havok Simulation, it jumps up slightly and floats as before.

Does any one have a fix for this? Making the pot static isn't an option, it has to be movable.

\$\endgroup\$
  • \$\begingroup\$ Do other tables work any better? Do other items sit better on that table? \$\endgroup\$ – Adam Dec 4 '13 at 23:17
  • \$\begingroup\$ Seems like a fairly broad question. There are a number of things that could be causing that behavior. You'll likely get better help on a forum specific to the Creation Kit or Havok. \$\endgroup\$ – MichaelHouse Dec 4 '13 at 23:54
  • 1
    \$\begingroup\$ I have the same problem with "any" object placed with Havok on "any" surface. I solved it by placing them with "F" and then turn on "Don't Havok Settle" in the object's property dialogue. This makes them still non-static but they will not "float up"... \$\endgroup\$ – Max Kielland Dec 4 '13 at 23:55
  • 7
    \$\begingroup\$ Questions about mods are on-topic here, folks. That said, this question is a touch unclear. Pictures would help. \$\endgroup\$ – user1430 Dec 5 '13 at 2:11
  • 1
    \$\begingroup\$ Is it possible the pot is floating because it's bounding box is slightly too large and it's pushing it up? (not an answer just a suggestion) \$\endgroup\$ – wolfdawn Jan 29 '14 at 17:09
1
\$\begingroup\$

This is a general answer for most 3d physincs engines, you can use one or both of this solutions:

1-) A solid object should have have the possibility of setting an inactive state, then the engine will not run any physic calculation for it until its first collision with any other object.

2-) Using proxy objects: The visible objects doesn't need to be the same that the physical object. You can use a proxy object scaled down a bit inside the visual object to fill the space between collisions.

That empty space between colliding objects is not a bug, is necessary for performance, when doing collision detection calculations. The engine should allow you to modify that value, if you set this value too small performance issues can arise and even wrong behavior like objects trespassing each other.

This answer is based experience using the same Havok engine in 3ds Max.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.