I'm using Unity 4 and trying to import a SketchUp Model into Unity and other Engines - but I can't get it to import correctly. Can anyone help me out?

  • \$\begingroup\$ No, dont work... \$\endgroup\$
    – AAssdff
    Sep 20, 2013 at 16:44
  • 1
    \$\begingroup\$ What, exactly, doesn't work? \$\endgroup\$
    – House
    Sep 20, 2013 at 16:55
  • \$\begingroup\$ When I put the 3d model gives it to me without the Texture \$\endgroup\$
    – AAssdff
    Sep 20, 2013 at 16:58

1 Answer 1


A quick Google search reveals this question over on the Unity forums, the steps provided there are as follows:

Sketchup Standard version or Pro Version - v8 or higher:

  • 1 Create/open the model with Google Sketchup
  • 2 Align the faces of the model (In the Monochrome mode--> the bright side should be up/front)
  • 3 Export in .dae format (Default settings!)

Blender - v3.55 or higher:

  • 4 Open the .dae file with Blender (If you want to see the textures - switch to texture rendering mode)
  • 5 Export to .fbx (Default settings)

Unity - v3 or higher:

  • 6 Create a new folder for your models (within the Assests tab) - Recommended
  • 7 Create a Folder called "Textures" within the new folder
  • 8 Drag/Import your model textures into the textures folder
  • 9 Drag/Import your .fbx model in the new folder (same layer as the "Textures" folder)

If you have done everything right, you should see a materials folder (near the textures folder) If you drag your object into the scene it should be fully textured If something is invisble - you have aligned the faces wrong (go back to step 2)

PS: If you have Google Sketchup pro - you can skip the blender part

The basic idea being that you'll need to export through an intermediate format to get the textures working. Another step by step tutorial is available here, which includes images to make things easier.

  • \$\begingroup\$ I did not understand this part: Align the faces of the model (In the Monochrome mode--> the bright side should be up/front) \$\endgroup\$
    – AAssdff
    Sep 20, 2013 at 17:06
  • \$\begingroup\$ View the question on the Unity forums, you'll find that question answered. \$\endgroup\$
    – House
    Sep 20, 2013 at 17:07
  • \$\begingroup\$ Unity can also import .dae files perfectly fine, and will convert them itself, so the Blender step is probably redundant. \$\endgroup\$ Sep 20, 2013 at 17:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .