0
\$\begingroup\$

I've been trying to export a simple footstep animation that I made in 3ds Max, but it either fails to export or is broken (imports into unity missing a few frames, or appears to have imported but won't play) every single time.

I've tried .fbx and .3ds, but neither works. I'd rather not use the Skin modifier, because it would require starting from scratch and learning a new system. Any ideas?

\$\endgroup\$
  • \$\begingroup\$ Can you edit the question to elaborate on "broken"? \$\endgroup\$ – MichaelHouse Jul 2 '13 at 23:38
  • \$\begingroup\$ Of course, I'll do that now. \$\endgroup\$ – Paul Ferris Jul 2 '13 at 23:39
  • \$\begingroup\$ In general, you need to bake any animations before bringing them into a game engine. If this applies to this setup i cannot say but that is my hunch. \$\endgroup\$ – Casper Beyer Jul 2 '13 at 23:45
  • \$\begingroup\$ Yeah, that's what I did in the work around. Further research seems to be saying that Physique is broken for FBX, so that explains my problem. \$\endgroup\$ – Paul Ferris Jul 2 '13 at 23:48
0
\$\begingroup\$

Here is a workaround, as originally by provided by Paul Ferris himself in an edit to the question, and reproduced here as community wiki:

I found a workaround, here it is if you're curious:

  • Create your biped, and make sure it lines up with your mesh.
  • Animate it
  • Export the mesh without Physique (or with Physique turned off), then delete it (the mesh)
  • Export the biped
  • Recombine in Unity (or whatever your game engine of choice is)
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.