1
\$\begingroup\$

I've just ported over and updated a bunch of FBX model loading code I had that worked with Direct X 10 to try and make it work with Direct X 11. Since that time, the FBX SDK I was using has been updated.

In my old program I linked to the following lib:

fbxsdk-2012.2-mdd.lib

Now, clearly I can't link to this as I don't have 2012.2 on my system. So, my thinking would be simply changing 2012.2 to 2014.1, but this didn't work and lead to the following error:

error LNK1104: cannot open file 'fbxsdk-2014.1-mdd.lib' 

So I tried to some googleing to see what the updated version of fbxsdk-2012.2-mdd.lib is. But I can't find anything. I tried taking out linking ot the 2014.1 lib but I get the following errors:

Error 36 error LNK2019: unresolved external symbol "void __cdecl fbxsdk_2014_1::FbxAssert(char const *,char const *,unsigned int,char const *)" (?FbxAssert@fbxsdk_2014_1@@YAXPBD0I0@Z) referenced in function "public: int & __thiscall fbxsdk_2014_1::FbxArray::operatorconst " (??A?$FbxArray@H@fbxsdk_2014_1@@QBEAAHH@Z)

So, looking in the FBX sample directory I opened up the ViewScene sample to see what it lib it linked to and I see that it wanted the following:

libfbxsdk-md.lib

So I did the same. But, my program claims it cannot open the file. And I'm at a loss as to what to do next.

Has anyone successfully managed to load FBX models into a Directx 11 application using 2014.1? If so, what do I need to do to get the correct lib linked?

\$\endgroup\$
2
  • \$\begingroup\$ Are you sure that your library paths are set up correctly. the FBX SDK installs to C:(or whatever)\Program Files\Autodesk\FBX... by default \$\endgroup\$
    – CobaltHex
    May 27 '13 at 2:41
  • \$\begingroup\$ Yeah man - my library path is C:\Program Files\Autodesk\FBX\FBX SDK\2014.1\lib\vs2012\x86 \$\endgroup\$
    – N0xus
    May 27 '13 at 9:29
1
\$\begingroup\$

For debug configurations just add:

C:\Program Files\Autodesk\FBX\FBX SDK\2014.1\lib\vs2012\x86\Debug\libfbxsdk-md.lib

To your project properties:

Properties -> Linker -> Input -> Additional Directories

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .