I got this, when I tried to load a model during runtime

XNA Framework Reach profile requires mipmapped Texture2D sizes to be powers of two, but this Texture2D is 800x800. Resize it to a power of two, or remove the mipmaps.

What does it mean? What do I have to do?

  • 1
    \$\begingroup\$ gamedev.stackexchange.com/questions/26187/… \$\endgroup\$ – Little Helper Apr 23 '13 at 19:45
  • 1
    \$\begingroup\$ The error means what it says. What is says is what the problem is. It also tells you what to do to fix it: "Resize it to a power of two, or remove the mipmaps.". Voting to close. \$\endgroup\$ – Maximus Minimus Apr 24 '13 at 20:42
  • 1
    \$\begingroup\$ Like @mh01 already mentioned, the error message already explicitly gives you two options about what you can do. \$\endgroup\$ – Christian Apr 25 '13 at 13:32

XNA Framework Reach profile

You are using the XNA Reach profile. This is a profile designed to make your game run on as many computers as possible. It is a pared-down subset of XNA's full functionality. The alternative is the HiDef profile, which exposes all of XNA's functionality, but has stricter hardware requirements.

requires mipmapped Texture2D sizes to be powers of two

One of the requirements imposed by the Reach profile is that textures with mipmaps have to have dimensions that are powers of two.

but this Texture2D is 800x800.

Your model is using a texture. The texture is 800x800 and has mipmaps (as is usually the case). 800 is not a power of two. The closest acceptable size would be 1024 (2 to the 10th power).

Resize it to a power of two, or remove the mipmaps.

Do one of these two things.

  • \$\begingroup\$ I resized the texture to 512x512, but I still get the same error \$\endgroup\$ – IMX Apr 23 '13 at 19:54
  • 3
    \$\begingroup\$ That would lead me to conclude that the texture that you're resizing is not the texture which is being loaded by XNA. What file format is your model? Some models can have their textures embedded within the model file, and I've also seen models exported with absolute texture paths. Try to confirm that you and XNA are talking about the same texture data. \$\endgroup\$ – Cole Campbell Apr 23 '13 at 20:01
  • 5
    \$\begingroup\$ its funny because all you had to do was read the error message back. \$\endgroup\$ – GameDev-er Apr 23 '13 at 23:21
  • 1
    \$\begingroup\$ Be sure to re-add the texture to your project after you resize it. The texture in your content folder is a copy of the file you select to add to your project, so editing the original will not correct the problem. (Or edit the one in your project's content folder.) \$\endgroup\$ – Seth Battin Apr 25 '13 at 1:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.