I am having a problem with Unity Android - every time I try to "build", a 'No Platforms Found' error pops up.

Thing is that I already have Android SDK in my computer (copied it into my G drive from the official .zip download). JDK is installed too.

I use Unity 4.0.0f7 Pro version, and have SDK Platforms 2.1 (API 7), 2.2 (API 8), 2.3.3 (API 10), 3.0 (API 11), 3.1 (API 12), 3.2 (API 13), 4.0 (API 14), 4.0.3 (API 15) and 4.2.2 (API 17).

How can I remove this error and build successfully?

P.S. I have already had a look at some of the threads in Unity website regarding this matter. None of the suggested answers has worked for me.

  • 1
    \$\begingroup\$ It may be that Unity is not "seeing" you Android SDK. Try removing it and re-installing it using the installer (not the zip archive). Make sure all the necessary folders (tools, etc) are in your "PATH" system variable. \$\endgroup\$ – Shivan Dragon Mar 26 '13 at 12:44
  • \$\begingroup\$ Done. Still not working. \$\endgroup\$ – Debojyoti Ghosh Mar 26 '13 at 16:37
  • \$\begingroup\$ Finally got it to work. :-) \$\endgroup\$ – Debojyoti Ghosh Mar 26 '13 at 21:07

Okay, here's how I managed to get it right - (assuming C drive to be your system drive)

1a. Install both 32 & 64-bit versions of Java in your C drive. 1b. Install Android SDK in any drive other than C. Download and use the .exe file - not the .zip file. 2. Install Unity in C drive. 3. Proceed to creating your Unity scenes and publishing them for Android.

Good luck! :-)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.