A while back I was looking for a way to export / load Models in XNA for animations. I took the advice from a comment, and tried using the "SkinnedModelProcessor" he linked me to. It worked great at home, but at school, I can't seem to get XNA to acknowledge that I have a custom pipeline in the solution. I've added the references to both the content project and the main project, but no luck. When I compile the example, Visual Studio complains that the content processor can't be found. When using my own project, Visual Studio doesn't have the custom Pipeline Processor as an option. When using the example, "SkinnedModelProcessor" is the value in the fields, but if I click on the combobox, that option isn't there, and VS still complains. Obviously this is a problem with how Visual Studio is configured, but I have absolutely no clue what I should do about it. Any suggestions guys? I guess I could build the code for animations at home, and not worry about it at school, but that sounds like the easy way out.


Some notes that are probably worth mentioning: * Any settings that I apply are reset when I log out. * Any changes to the C drive are reset when the computer shuts down. * The project is stored on a network location, which has caused problems in the past, evidently. ( Although, I personally don't know what these problems would include ).

  • \$\begingroup\$ Your content project needs to have reference to pipeline extension project. Also you must be able to build your pipeline extension project - look to the directory with your pipeline extension project to bin/Debug/ directory if your .dll is there \$\endgroup\$ – Kikaimaru Feb 1 '13 at 17:28
  • \$\begingroup\$ It is -- the references are all set -- and the solutions build individually ( save for the model files ). It works flawlessly at home, as well. \$\endgroup\$ – Full Metal Feb 1 '13 at 17:37

If anybody else has this problem, I'll point out a work-around I've discovered. The problem was that the project was stored on a network. For now, I'll just have to copy the project's files onto my desktop after I log on, and return it to my network location for saving. It's a pain, but I don't see many other alternatives here.


Taking some shots in the dark...

Some things to troubleshoot:

  • Is XNA installed properly? Does a example project work on the school computer?
  • Are you copying over the entire project folder? There are a lot of setting files that need to be in place for visual studios to discover and recognize your assets.
  • When you create the project on the school computer, are you in fact choosing to create an XNA windows application, as apposed to a C# application or something else?
  • Does Visual Studios actually recognize your network location? Is it a place you can reach with the command prompt (with the [driver-letter]: command, perhaps)? Visual Studios will choke if it cannot reliably find a location.

Build information is program agnostic, it should be part of your project files. If the computer gets reset every night, it should not matter as long as the project is preserved as a whole.

The only other thing I can think of is to make sure there is no directory mis-match between your home computer and school computer.

  • \$\begingroup\$ Replies in order: * Well, I have absolutely no clue if it's installed properly. The school is pretty non-disclosing about that sort of information, especially towards students. * I'm not quite sure what you mean by this, to be honest. * Yes, I am. * It does, but every time I open it, Visual Studio whines about it not being a "trusted" resource. ( I frequently use Python via command prompt in a directory on my "My Documents" directory -- where my Visual Studio information is also stored ) \$\endgroup\$ – Full Metal Feb 2 '13 at 4:42
  • \$\begingroup\$ I guess it would be worth asking what versions(s) of Visual Studios you are running? If the box that is coming up about "trust" is what I think it is, you may have a really old version of VS... \$\endgroup\$ – Kirbinator Feb 3 '13 at 20:48
  • \$\begingroup\$ See if you can get this sample project working: link \$\endgroup\$ – Kirbinator Feb 3 '13 at 20:52
  • \$\begingroup\$ I'm using Visual Studio 2008 at school. I have C# 2008 express at home. ( I can't be bothered to hack XNA 3.1 into Visual Studio 2012, so I installed express in addition to 2012 at home ). Also, I've tried to get that sample to work as well as just the "Simple Skinned Sample". \$\endgroup\$ – Full Metal Feb 4 '13 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.