My goal is to create a simple groundplane in UDK (11/2012 version, fresh install) that the user will be able to run around on. My requirements are therefore very basic and I tried to whip something up quickly in the editor. I created a circular (cylinder) plane and applied a material. I added a Blocking Volume, a Lightmass Importance Volume, and a Sky Light. I built everything and get no errors. The map played fine on my system.

I transferred the file to another system with the same version of UDK (also a recent install). When I try to play the map, I plunge to my death. Though I have verified that my player start position is above the ground, I seem to start below the ground looking up at it. What could cause a map that works great on one system have such a positioning issue on another system?

I believe this is a valid question. I'm obviously going to need to systematically test things and I already have tried moving the player start etc. However, I will need to have some idea of what can differ between installs. I'm extremely new to the UDK.


  • \$\begingroup\$ "Works on my system" is a classic joke in development. Try importing the map into a different instance than where you created it on the first system. It's basic troubleshooting. Narrow down the variables to try to find which part of the process is causing the issue. Change the start position to be 15 units above ground, see what happens on the other system. Experiment and you'll likely find the issue. \$\endgroup\$
    – House
    Feb 1 '13 at 18:58
  • \$\begingroup\$ I understand what you're saying but perhaps I should have said works on my install. My question still stands as to what could be different between two fresh installs. It is a valid question because I'll need to know the answer before I can begin to systematically troubleshoot. \$\endgroup\$
    – Eric Marsh
    Feb 1 '13 at 19:35
  • \$\begingroup\$ I'm just making a suggestion for finding your own answer. It's more likely to get you an answer quickly. Since you don't care about all the possible differences, only about what might be causing this issue. Additionally taking these steps on your own rules out any chance of it being an issue with how you're exporting the map or importing it on the other machine. Because it might not be a difference in the installs at all. I didn't say it was an invalid question, I'm just trying to make suggestions to help. \$\endgroup\$
    – House
    Feb 1 '13 at 19:40
  • \$\begingroup\$ I literally spent 5 hours today on this and more yesterday on related issues. I've Googled and had theories and worked on things but ultimately it still doesn't work. I don't see how this was an inappropriate question and downvoting it only hinders me in finding an answer. Also, from stackoverflow.com/privileges/vote-down : "Down-voting should be reserved for extreme cases. It's not meant as a substitute for communication and editing." and "Use your downvotes whenever you encounter an egregiously sloppy, no-effort-expended post" \$\endgroup\$
    – Eric Marsh
    Feb 1 '13 at 19:43
  • \$\begingroup\$ Eric, I didn't down vote you. I've only commented trying to help you. Sorry that whoever down voted didn't comment, but you shouldn't assume it's the first person to comment. \$\endgroup\$
    – House
    Feb 1 '13 at 19:52

I can't give you an absolute solution to your problem, but here are some things that you can do to help narrow it down:

  • Verify that the ground plane you made has proper collision settings. Alternatively, if it suits your needs, try using a landscape instead. (http://udn.epicgames.com/Three/LandscapeCreating.html)
  • Verify that both systems' maps are using the same game type, world info, and zone info information, by going to the following menus:
    • View -> World Properties -> World Info
    • View -> World Properties -> Zone Info
    • View -> World Properties -> Game Type
  • If you are using a custom game type or other custom settings, verify that both computer's ini settings are similar in defaultgame.ini and defaultengine.ini
  • If the above don't work, log both the playerstartloc and player's spawn location using the log functionality in unrealscript or in kismet. If these vectors are different, it will help you narrow it down. If you are basing your game on UTGame you may run into problems like this because UTGame performs very specific actions that may not suit your game.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.