I've been trying to texture a model using Blender, but when I draw on the UV Editor it doesn't show up on the model, and I can't draw on the model itself. I've tried saving the image and the 3D View is set to Texture. Everything seems to be in order and I've followed several tutorials, but none of them seem to work with the version I'm using (2.64-- update was necessary for import plugin) and I'm absolutely stumped.

How can I draw textures to the model? If not within Blender itself, how do I export/import the textures?

EDIT: Vertex Paint works, though it is insufficient for my purposes. In addition, moving to the rendered view produces a solid-color model with none of the applied textures.

  • \$\begingroup\$ Stupid question : Are you using the right view to see the texture on the model (Textured and not solid/wireframe)? \$\endgroup\$ Commented Oct 7, 2012 at 11:17
  • \$\begingroup\$ Yes, I'm using the Texture setting in the 3D View panel. I've also tried Rendered and Material with no luck. \$\endgroup\$
    – Passage
    Commented Oct 7, 2012 at 11:23

1 Answer 1


There is a common cause for textures not showing up in the viewport in Blender. It's a bit confusing, but I'll try to make it clear. You can assign textures to a mesh in two different places!

You can set textures on materials. These textures will always show up in renders but not always in the viewport. Assign textures to materials using the material properties.

You can also set textures on faces individually. These will never show up in renders, but can be seen in some viewport configurations. Assign textures to faces using the UV/Image editor by selecting faces in the 3d view and changing the current image in the uv/image view. Selecting a face in the 3d view will change the image in the uv/image view.

The texture assigned to a face is the texture that will receive texture paint operations on that face.

Which of the textures show up in the viewport depends on both the viewport display settings (3d view properties panel -> display -> shading) and the viewport shading mode.

  1. With single or multi-texture shading, only the face textures will be displayed.
  2. If the Cycles renderer is enabled, only the material textures will be displayed.
  3. With GLSL shading and "textured solid" enabled, face textures will be displayed in 'solid' mode, and material textures in 'textured' mode.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .