I just started with andengine, so this maybe gonna be silly question. How to make my sprites more smooth while I rotate them? Or maybe it because this is screenshot from tablet?

enter image description here

Thanks JohnEye it works:

enter image description here

Just need to change my BitmapTextureAtlas from:

BitmapTextureAtlas carAtlas = new BitmapTextureAtlas(this.getTextureManager(),100, 63);


BitmapTextureAtlas carAtlas = new BitmapTextureAtlas(this.getTextureManager(),100, 63, TextureOptions.BILINEAR);    
  • 3
    \$\begingroup\$ I don't use Andengine, and I couldn't find the info in a search but you'll want to us antialiasing for this. If it doesn't offer that natively you can change the opengl texture calls to use nearest instead of linear. You may also try using higher resolution sprites. \$\endgroup\$
    – House
    Oct 4, 2012 at 21:36

1 Answer 1


Your TextureOptions settings are likely to be the cause, see the call that you use for creating your TextureAtlas. Try the different TextureOptions and see which one you like the most. For more information, see the related thread on the AndEngine forum.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .