I'm using XNAWinForm series 2 from App Hub for some task that needs 3d rendering. It works fine on my PC, but I have problems in running this code on other machines.

I installed XNA framework redistributable on that machine, I tried 32 and 64bit computers and still its not working. Even the code on app hub is not working on other machines.

What should I do?

  • 1
    \$\begingroup\$ You should collect and analyze any error messages produced. \$\endgroup\$
    – House
    Aug 20, 2012 at 18:10
  • \$\begingroup\$ there is no error when i debug it, as i said, it works fine on my machine. and it on other machines before run completely, it closes, and no error again. \$\endgroup\$
    – naprox
    Aug 20, 2012 at 18:19
  • \$\begingroup\$ Have you tried starting the executable from the command line and seeing what it returns? Or tried using Windbg or some other debugger and attaching it to the executable? You should also add error handling to your program. I assume since you're doing content loading it's not finding the content it needs and crashing out. Make sure when that happens that you output a stack trace and an error message. \$\endgroup\$
    – House
    Aug 20, 2012 at 18:41

1 Answer 1


You need to have the full XNA game studio installed on every machine that will use your tool. From the WinForms2 sample page you linked to:

Note also that the XNA Framework redistributable installer doesn't include the Content Pipeline. This sample will run only on computers that have the XNA Game Studio installed.

You also aren't allowed to distribute the full XNA studio installer in your install package, so if you are creating a tool to be distributed with your game the content pipeline isn't a great fit. It's likely not reasonable to expect end-users to install a developer tool to be able to use your custom tool.

  • \$\begingroup\$ so it means there is no solution for that? i mean changing the code to not use XNA dveloper tool or content pipeline? and i must install full XNA developer? \$\endgroup\$
    – naprox
    Aug 20, 2012 at 20:18
  • 2
    \$\begingroup\$ Yes, in order to build using the content pipeline (even in an automated tool) you need to have the full XNA game studio installed. There is no way around it - the required assemblies are not installed using the redistributable alone. \$\endgroup\$ Aug 20, 2012 at 20:20

Not the answer you're looking for? Browse other questions tagged .