They say naming things is one of the hardest problems in computer programming. They were right.
Given the pseudocode below, what is a more appropriate name for this collection of properties? "Course", "Route", "Heading", "Orientation" all don't capture it.
class NewtonianStuff { // <-- Needs a better name
vec3 position, velocity, acceleration; // <-- What is this group called
quat rotation;
};
class SpaceShip {
NewtonianStuff xxxxxx; // <-- What do you call that
};
Perhaps that collection is too abstract. What is the formal name for this collection of properties?
vec3 position, velocity, acceleration;
The best I can come up with is "PositionAndDerivatives", which doesn't really flow.