0
\$\begingroup\$
  1. I had created a new scene, which didn't have sky and directional light.

  2. To solve this, I created a new skybox, then added to the maincamera. But there was no difference to scene & game view. enter image description here

  3. Then I realised that the main issue might be the 2D/3D setting, not the skybox.

  4. I went to 'Edit > Project Settings > Default Behaviour Mode > 3D' But there was no difference to scene & game view. (Even after quitting and reopening it, there's no change) This scene is Basic URP.
    enter image description here

I want to work in a 3D environment that has a sky and a directional light. What should I do? Thank you in advance.

\$\endgroup\$
7
  • \$\begingroup\$ Does this answer your question? 3D vs 2D mode only changes the default settings used when importing images or creating a new scene. Toggling this setting will not retroactively alter the contents of a scene you've already created. \$\endgroup\$
    – DMGregory
    Commented Jun 17 at 11:06
  • \$\begingroup\$ Then what is causing the scene to not have a sky and directional light? I have the same problem when I create a new scene. I am so stuck... \$\endgroup\$ Commented Jun 17 at 13:21
  • \$\begingroup\$ You already posted a question about that. You do not need to post another question about the same topic to guess at a potential answer. \$\endgroup\$
    – DMGregory
    Commented Jun 17 at 14:50
  • \$\begingroup\$ Your scene looks like 3D to me. Can you rotate the directional right 360 degrees on each of the following axis: X, Y, and Z (separately - one axis at a time - 360 degrees for each axis) ? Sometime, the directional light does not point toward the objects, and so, the object does not light up. \$\endgroup\$ Commented Jun 18 at 3:51
  • \$\begingroup\$ Also, (1) Make sure the light color is WHITE or Yellow, and NOT BLACK. (2) Increase the intensity of the light to 2 to see if it works. \$\endgroup\$ Commented Jun 18 at 3:53

0

You must log in to answer this question.

Browse other questions tagged .