0
\$\begingroup\$

I'm developing a racket-ball behavior, the expected behavior is similar to a realistic tennis racket and ball, meaning both velocity and ang. velocity should be precisely applied when the ball "exits" the racket. The velocity seems to be pretty stable and expected, however, the effect of the friction seems to be ignored sometimes, mostly on fast-collisions - that causes the ball to leave the racket with simply no ang. velocity effect, like it never hit the racket. Or, well, like the friction is 0.

The friction values of the ball & racket are set to 1. I've tried many approaches and some workarounds helped (such as setting continuous speculative detection and expanding the contactOffset), however the friction issue persists and nothing seems to help. I can try and apply the ang. velocity manually when the ball leaves the racket but that will definitely be a dead-end solution, and I was hoping to find a simpler solution.

This actually happens not just with the racket and the ball, but also when the ball bounce on a plane - on fast-collisions it behaves like it's bouncing on ice, like there's no friction whatsever.

\$\endgroup\$
2
  • \$\begingroup\$ What Friction Type are you using in the Physics settings? \$\endgroup\$
    – Kevin
    Commented Apr 22 at 21:24
  • \$\begingroup\$ The default Patch Friction. I tried the other ones, it behaves pretty much the same. \$\endgroup\$ Commented Apr 23 at 8:27

0

You must log in to answer this question.

Browse other questions tagged .