0
\$\begingroup\$

In my webgl build skybox is completely purple on mobile Chrome browser but works fine on PC and mobile firefox. Is there any fix for this?

Edit: This is my skybox material and I didn't do anything special just assign it

Edit 2: It appears same problem happens on Opera and Edge for mobile while safari and mozila work fine.

\$\endgroup\$
2
  • \$\begingroup\$ Can you show us what skybox material you're using and how you've configured it in your scene settings? \$\endgroup\$
    – DMGregory
    Apr 2 at 13:55
  • \$\begingroup\$ I edited the question with that info \$\endgroup\$
    – Ivan
    Apr 2 at 14:03

2 Answers 2

0
\$\begingroup\$

I ended up using Mobile skybox shader and it seams to work, only problem here is that it needs split textures for skybox.

\$\endgroup\$
-2
\$\begingroup\$

Have you imported Chrome, Opera and Edge into your script?

\$\endgroup\$
3
  • \$\begingroup\$ How do you mean I don't really have a script its just skybox \$\endgroup\$
    – Ivan
    Apr 3 at 13:00
  • \$\begingroup\$ that's weird, how do you even launch the program without specifying what browsers it can support? \$\endgroup\$
    – lucutes
    Apr 6 at 11:13
  • \$\begingroup\$ This does not provide an answer to the question. To request clarification from an author, leave a comment below their post. You can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. \$\endgroup\$
    – Pikalek
    Apr 16 at 3:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .