0
\$\begingroup\$

Working on a simple board game. The game renders the board with jagged lines.

The models were built in Blender. Everything is .obj. The White part and the border are separate objects.

I've tried increasing resolution and increasing poly count on the objects but it is still rendered with jagged lines.

Is there a way to sharpen the lines? Either in Blender or Godot?

Sample Render

\$\endgroup\$
3
  • \$\begingroup\$ Do you mean anti aliasing? \$\endgroup\$
    – Mangata
    Jan 12 at 6:51
  • \$\begingroup\$ Seems so, thanks! \$\endgroup\$
    – gNerb
    Jan 12 at 6:54
  • \$\begingroup\$ Playing around the MSAA 3D seems to have the biggest impact, set it to 8x (for now) since the game is simple enough I don't expect the performance hit to be very impactful. \$\endgroup\$
    – gNerb
    Jan 12 at 6:58

1 Answer 1

1
\$\begingroup\$

Answer provided by Mangata in the comments to the original post.

Note: the information within was tested within Godot 4.0. I Can't speak to earlier versions.

The solution was to implement anti-aliasing. Information outlined in this article: https://docs.godotengine.org/en/stable/tutorials/3d/3d_antialiasing.html

Specifically, from within project settings, enable advanced settings: enable advanced settings

Then in the navigation tree on the left, expand the rendering group and locate Anti-Aliasing: locate anti aliasing

I elected to use MSAA 3D 8x originally but down-scaled to 4x for performance.

Result: Result

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .