I want to develop a game in unity, just a small scale simple game without heavy computation nor complicated feature, and does not use a lot of ram either (2-3 GB). I want player with "outdated device" (device that does not support OpenGL 3.0 or higher) still able to play my game because apparently these outdated device is still widely used, especially in poor region, due to their cheap price. Forcing OpenGL 3.0 would prevent these device from playing my game despite my game using feature that can be implemented in OpenGL 2.0, so this does not make sense to use OpenGL 3.0 in the first place.

I try to find information regarding OpenGL version used by unity, however i have only found https://docs.unity3d.com/Manual/OpenGLCoreDetails.html. In that article it was said

This scales from OpenGL 3.2 to OpenGL 4.5 depending on the OpenGL driver support.

I even tried changing the documentation version to the oldest one possible (2017.1) and it still said the same exact sentence.

Does this mean OpenGL older than 3.2 is not supported by Unity ? or is there any workaround to this ?


1 Answer 1


According to this post on Unity Forums website, OpenGL 2 support was dropped since Unity 5.5:

...since Unity 5.5, OpenGL core profile 3.2 is the minimum supported version.

And OpenGL ES 2 support was dropped in Unity 2022:

Unity 2022 will offer no GLES2 support for Android and will instead raise an error on importing an older project.

So, basically, you'll need to use an Editor version pre 5.5 (5.4 and older). You can still download previous Editor versions from the archive: here.

  • 1
    \$\begingroup\$ ah i see, thank you. \$\endgroup\$
    – aaa
    Dec 10, 2023 at 8:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .