3
\$\begingroup\$

There is a red thing inside of my capsule object that shows when running the game in Unity. How do I make it invisible? I have tried looking at the capsule collider, but I couldn't find anything to make it invisible. Please take a look at the screenshots added to this question.

enter image description here

enter image description here

\$\endgroup\$
4
  • 1
    \$\begingroup\$ That looks like you just hit the Gismos toogle. \$\endgroup\$
    – Zibelas
    Nov 27, 2023 at 17:14
  • 1
    \$\begingroup\$ To clarify ... Top-right hand corner of the play window is a "Gizmos" drop-down which lets you pick which gizmos are visible. Should only apply to running in the editor, not final builds. \$\endgroup\$
    – Basic
    Nov 27, 2023 at 17:26
  • \$\begingroup\$ @Zibelas That seems to be it. I appreciate the help. \$\endgroup\$
    – Cezar P
    Nov 27, 2023 at 17:44
  • 1
    \$\begingroup\$ @Basic Thanks, that solved it indeed. \$\endgroup\$
    – Cezar P
    Nov 27, 2023 at 17:44

1 Answer 1

3
\$\begingroup\$

This is a gizmo drawn by one of the scripts you have running in this scene. Look for functions called OnDrawGizmos or OnDrawGizmosSelected. They'll be calling Gizmos.DrawWireSphere to draw this item, so you can comment out that line if you never want to see this.

You can also click the "Gizmos" button in the top bar of your Game tab to turn off drawing of gizmos in the game view.

\$\endgroup\$
1
  • \$\begingroup\$ I appreciate the answer, that solved it. \$\endgroup\$
    – Cezar P
    Nov 27, 2023 at 17:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .