0
\$\begingroup\$

In Unreal Engine 5, whenever I run the game, the viewport becomes very blurry with strange artifacting and twitching. This only happens when I'm attached to the player controller. If I eject from it, the viewport is fine. If I stop the simulation, it's fine. It's only when the simulation is running and I'm in the player. I tried making a new, blank project and it does the same thing.

If I stay idle (not moving) long enough, the picture starts to clean up. What it looks like to me is denoising on top of low sample rendering. And as the render gets higher quality (as more samples process) the picture slowly clears up.

How do I stop this and go back to default behavior?

Broken viewport, as player

Blurry view

Working viewport, ejected from player

Sharp view


Disabling AA hasn't fixed the issue but has made the effect less blurry, showing the raw pixels beneath. It seems the editor window is just low resolution, but Screen Percentage is set to 100.

Low-res view

\$\endgroup\$
2
  • \$\begingroup\$ Do a Stat FPS command in each mode and compare the difference. You have turned on RTS or DLSS or a high anti-aliasing mode and the video card cannot keep up. \$\endgroup\$
    – agone
    Commented Nov 14, 2023 at 2:27
  • \$\begingroup\$ Thanks for the tip, but could you be more specific? I tried Anti Aliasing Method of 'None' and disabled Hardware Ray Tracing. The issue persists. New image attached. Stat FPS shows 110 FPS in edit, simulation and 'ejected' simulation. I have a Nvidia RTX. \$\endgroup\$
    – Candle
    Commented Nov 14, 2023 at 20:49

0

You must log in to answer this question.

Browse other questions tagged .