I built a project with Unity version 2023.3.0a and I had many problems with this version so I opened my project with version 2022.3.10f1, but I have some errors.

I tried to reimport my project packages using package manager, but I still have some errors like:

Library PackageCacheicom.unity.2d.common@9.0.21RuntimeIntemailBridgelintemalEngineBridge ca ( 21,28 ) ror CS1061 : SpriteRenderer does not contain a definition for SetBoneTransforms and no accessible extension method " SetBone Transforme accepting a first argument of type " SpriteRenderer could be found ( are you missing a using directive or an assembly reference ? )

  • \$\begingroup\$ If you just started the project and it doesn't have many files in it, it might be easier to create a new project in 2022.3.10f1 and copy the files from the Assets folder into the new project. \$\endgroup\$
    – Kevin
    Oct 6 at 20:27
  • 1
    \$\begingroup\$ Sounds like this question on Stackoverflow is about the exact same error. I found it by entering "SpriteRenderer does not contain a definition for SetBoneTransforms" into a search engine. Googling error messages can be really helpful in solving problems. \$\endgroup\$
    – Philipp
    Oct 6 at 20:33
  • \$\begingroup\$ It looks like the error message got seriously garbled when you copied/transcribed it into your question. Please take the time to review what you've posted and ensure it reads correctly in its entirety. \$\endgroup\$
    – DMGregory
    Oct 6 at 21:20


You must log in to answer this question.

Browse other questions tagged .