0
\$\begingroup\$

I want to build a project with a release aab version.

Unity asks me to create a keystore, and when I create one, it show this message:

Android/2023.1.911/Editor/2023.3.0a6/Editor/Data/PlaybackEngines/AndroidPlayer/Tools \ sdktools.jar " CommandinvokationFailure : Unable to create keystore . Please make sure the location of the keystore is valid . CommandinvokationFailure : Unable to create keystore . Please make sure the location of the keystore is valid .

Android 2023.1.9f1 | Editor 2023.3.0a61Editor Data PlaybackEngines Android Player \ OpenJDK bin java.exe -Xmx4096M -Dcom.android.sdkmanager.toolsdir = " E : Android2023.1.9f11Editor 2023.3.0861Editor Data \ PlaybackEngines Android Player SDK cmdline - tools 16.0 " -Dfile.encoding - UTFB - jar

When I choose a different location, it also shows this message and refuses to create a keystore

\$\endgroup\$
4
  • \$\begingroup\$ Can you edit your question to show us the exact steps you're taking to create this keystore, and what location you're trying to create it in? \$\endgroup\$
    – DMGregory
    Sep 30 at 13:07
  • \$\begingroup\$ Searching for the text of the error message, I find this Unity support thread which claims the problem has been fixed in versions 2023.1.11f1, 2023.2.0b7 and 2023.3.0a4 - have you tried updating to one of these versions? \$\endgroup\$
    – DMGregory
    Sep 30 at 13:24
  • \$\begingroup\$ I use 2023.3.0a6 version \$\endgroup\$
    – Ali Ahmed
    Sep 30 at 13:31
  • \$\begingroup\$ I notice "2023.1.911" / "2023.1.9f" in the error messages - is it possible your Android support tools are from an older version? Uninstalling and reinstalling may help with this. \$\endgroup\$
    – DMGregory
    Sep 30 at 13:36

0

You must log in to answer this question.

Browse other questions tagged .